Credit Card Transactions Temporarily Down

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Feb 12, 2025 - 17:56 EST

Investigating

We are aware of an issue affecting Credit Card transactions and are actively working to resolve the issue. All customer accounts and funds remain secure. Further updates to follow.
Posted Feb 12, 2025 - 17:36 EST
This incident affected: Gemini Credit Card™.