Service disruption - GUSD/USD pair temporarily unavailable on ActiveTrader
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Mar 25, 2024 - 06:50 EDT
Investigating
The GUSD/USD pair is temporarily unavailable on ActiveTrader. As a workaround, users can use the Web/Simple interface to trade GUSD/USD pair. All customer accounts and funds remain secure. We will provide further updates as they become available.
Posted Feb 28, 2024 - 23:09 EST
This incident affected: Gemini ActiveTrader™.