Gemini App is down

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted May 08, 2025 - 17:46 EDT

Update

We are continuing to investigate this issue.
Posted May 08, 2025 - 11:42 EDT

Investigating

We are currently investigating this issue.
Posted May 08, 2025 - 11:32 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95%.