iOS Mobile App Price Widget

Incident Report for Gemini Exchange

Resolved

This issue has been resolved.
Posted May 02, 2022 - 09:03 EDT

Investigating

The price widget on the iOS mobile app is currently not available. We are working to resolve this and appreciate your patience.
Posted Apr 23, 2022 - 13:51 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95%.