Gemini Credit Card Mobile App Outage

Incident Report for Gemini Exchange

Update

We are investigating mobile app credit card payment issues and payments can be successfully made on the website
Posted Feb 25, 2026 - 16:35 EST

Update

We are continuing to investigate this issue.
Posted Feb 25, 2026 - 16:34 EST

Investigating

We are investigating mobile app credit card payment issues and payments can be successfully made on the website
Posted Feb 25, 2026 - 16:34 EST
This incident affects: Gemini Mobile App: Uptime SLA 99.95% and Gemini Credit Card™.