Issue Placing "No" Orders on Mobile Predictions

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Dec 18, 2025 - 17:52 EST

Monitoring

A fix has been released in app version 25.1214.1. An App Store update will be available later today.
Posted Dec 16, 2025 - 13:59 EST

Investigating

We’re currently having an issue with placing orders on the "No" side for predictions. This is only affecting some mobile users. We’re investigating and will provide an update as soon as possible.
Posted Dec 16, 2025 - 12:37 EST
This incident affected: Gemini Mobile App: Uptime SLA 99.95%.