Service Disruption - Web and Mobile Apps
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Mar 19, 2021 - 19:02 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2021 - 12:36 EDT
Investigating
We investigating reports effecting Web and Mobile trading interfaces. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Mar 19, 2021 - 12:26 EDT
This incident affected: Gemini ActiveTrader™, Gemini Web UI, and Gemini Mobile App.