Service Disruption - Cosmos Withdrawals
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jul 17, 2024 - 21:07 EDT
Investigating
Cosmos withdrawals are currently unavailable while we investigate an issue. All customer funds are safe. We will be sure to follow up with more information as soon as it is available.
Posted Jul 17, 2024 - 20:04 EDT
This incident affected: Digital Currencies (Cosmos Deposits and Withdrawals).