Service Disruption: Deposit Address Generation
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Nov 12, 2023 - 09:15 EST
Update
We are continuing to investigate this issue.
Posted Nov 08, 2023 - 18:07 EST
Investigating
We are currently investigating an issue with deposit address generation on all networks.

All customer accounts and funds remain completely secure. Updates will be provided once they are available.
Posted Nov 08, 2023 - 18:06 EST
This incident affected: Gemini Mobile App: Uptime SLA 99.95% and Gemini.com website.