Polkadot transfers temporarily disabled

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 16:07 EST

Investigating

Polkadot deposits and withdrawals will be disabled for 12 hours starting 11/03/2025 at 10:59 PM PST. All customer accounts and funds remain secure. Further updates to follow.
Posted Nov 03, 2025 - 20:25 EST
This incident affected: Digital Currencies (Polkadot Deposits and Withdrawals).