Gemini Clearing - sporadic delays in settlement on Clearing trades
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Dec 14, 2021 - 10:35 EST
Identified
Gemini has identified an issue causing sporadic issues with Gemini Clearing, that may result in some orders not settling within the expected window. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Dec 09, 2021 - 21:05 EST
This incident affected: Gemini Clearing.