Crypto Deposits Temporarily Delayed

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 14:51 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 11, 2025 - 18:31 EDT

Investigating

We are investigating an issue impacting crediting of incoming deposits of select assets. We will share further updates here as our investigation progresses.
Posted Apr 11, 2025 - 18:30 EDT
This incident affected: Digital Currencies (Litecoin Deposits and Withdrawals, Zcash Deposits and Withdrawals, Bitcoin Cash Deposits and Withdrawals, Filecoin Deposits and Withdrawals, Dogecoin Deposits and Withdrawals, Tezos Deposits and Withdrawals, Avalanche Deposits and Withdrawals).