Degraded Performance - SOL, ETH/ERC-20, BTC, ARB, OP Withdrawal Delays

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 00:03 EDT

Investigating

We are currently investigating delays regarding SOL, ETH/ERC-20, BTC, ARB, OP withdrawals. All customer accounts and funds remain secure. Further updates to follow.
Posted Apr 14, 2025 - 21:53 EDT
This incident affected: Crypto Deposits and Withdrawals.