Service Disruption - Services Currently Unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Aug 13, 2022 - 12:01 EDT
Investigating
Gemini is investigating reports of potential service disruptions. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Aug 13, 2022 - 10:31 EDT