Degraded performance – SGD Withdrawals

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted 7 days ago. Apr 04, 2025 - 09:33 EDT

Investigating

We’re currently investigating an issue impacting SGD withdrawals. Some users may be experiencing failures or delays when attempting to withdraw funds. All customer accounts and funds remain completely secure. We will provide updates as soon as they become available.
Posted 7 days ago. Apr 04, 2025 - 08:15 EDT
This incident affected: Fiat Deposits and Withdrawals.