Wire Transfer Delays
Incident Report for Gemini Exchange
Resolved
This incident has been resolved. All delays have cleared and wire transfers are operational.
Posted Mar 24, 2020 - 11:59 EDT
Update
Inbound wires are now being processed without any delays. There are some residual delays in outbound wires that we expect to clear up by end of day today (3/24/20). As always, don't hesitate to reach out to support@gemini.com with any questions.
Posted Mar 24, 2020 - 10:03 EDT
Monitoring
On Friday, March 20th, a third party vendor that is used for wire processing experienced an unexpected system issue that resulted in delays processing both inbound and outbound wire transfers. The issue has since been resolved, however, Customers should expect residual delays as pending wire backlogs are cleared. Pending wires from Friday are expected to be processed by end of day today (3/23/2020).
Posted Mar 23, 2020 - 11:08 EDT
This incident affected: U.S. Wire Transfer Deposit and Withdrawals.