XRP Deposit & Withdrawal Delayed Processing

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted May 28, 2025 - 12:53 EDT

Investigating

We are experiencing issues processing XRP deposits and withdrawals. All customer accounts and funds remain secure. Updates will be provided once they are available.
Posted May 19, 2025 - 22:02 EDT
This incident affected: Digital Currencies (XRP Deposits & Withdraw).