Service Disruption - GBP Deposits
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Feb 15, 2023 - 11:08 EST
Update
We are continuing to work on a fix for this issue.
Posted Dec 07, 2022 - 12:51 EST
Identified
Gemini has implemented a fix for this issue for Web and iOS environments.

Android users in the UK may still experience issues when attempting GBP deposits. Impacted users may still make deposits via the Gemini website while our teams work on deploying a fix.
Posted Dec 07, 2022 - 12:46 EST
Investigating
Gemini has identified an incident impacting GBP deposits. All funds remain secure as we work to fully restore service. We will be actively updating the status of these transfers.
Posted Dec 07, 2022 - 11:17 EST
This incident affected: Fiat Deposits and Withdrawals.