Asset Prices Displaying Incorrectly for Non-USD Denominated Accounts
Incident Report for Gemini Exchange
Resolved
Issue has been resolved and all asset prices should now be showing as expected.
Posted Feb 05, 2024 - 23:10 EST
Monitoring
A fix has bene implemented and we are monitoring the roll out
Posted Feb 05, 2024 - 23:07 EST
Investigating
We are investigating issues impacting the calculation of asset prices for users whose accounts are denominated in currencies other than USD. We will share further updates here as our team's investigation progresses.
Posted Feb 05, 2024 - 18:07 EST
This incident affected: Gemini ActiveTrader™, Gemini Mobile App: Uptime SLA 99.95%, and Gemini Web UI: Uptime SLA 99.95%.