Credit Card Support Calls Unavailable

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 13:44 EDT

Investigating

Customers are currently unable to reach Credit Card customer support by phone. All customer accounts and funds remain completely secure.
Posted Sep 16, 2026 - 12:35 EDT
This incident affected: Gemini Credit Card™.