Degraded Performance – Account Registration on Android App

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted May 08, 2025 - 11:26 EDT

Investigating

Android app clients are experiencing issues uploading documentation. Please utilize web platform to upload during investigation. Updates will be provided once they are available.
Posted May 05, 2025 - 09:50 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95%.