New Account Registration Is Currently Unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Aug 23, 2024 - 13:17 EDT
Investigating
New Account Registration Is Currently Unavailable. All customer accounts and funds remain secure. Further updates to follow.
Posted Aug 23, 2024 - 12:37 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95% and Gemini Web UI: Uptime SLA 99.95%.