Service Disruption - Web and Mobile Apps
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Mar 19, 2021 - 22:00 EDT
Identified
We are investigating reports effecting Web and Mobile trading interfaces. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Mar 19, 2021 - 21:19 EDT
This incident affected: Gemini Web UI and Gemini Mobile App.