Payment Method Display Issue – Unable to View or Select Bank

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted 4 days ago. Apr 04, 2025 - 01:06 EDT

Investigating

Payment method display issue via mobile. Unable to select your bank during purchase. All customer accounts and funds remain completely secure. Updates will be provided once they are available.
Posted 4 days ago. Apr 03, 2025 - 12:30 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95%.