Filecoin Deposits and Withdrawals are Temporarily Unavailable
Incident Report for Gemini Exchange
Resolved
A fix has been deployed for this issue. No further impact is anticipated at this time.
Posted Nov 03, 2020 - 15:19 EST
Investigating
Filecoin deposits and withdrawals are currently unavailable while we investigate a technical issue.
Posted Nov 03, 2020 - 14:53 EST
This incident affected: Digital Currencies (Filecoin Deposits and Withdrawals).