Password Reset Degraded Performance

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Jun 06, 2025 - 12:32 EDT

Investigating

Password reset functionality is currently experiencing degraded performance due to CAPTCHA issues. All customer accounts and funds remain fully secure. We will provide updates as soon as more information becomes available.
Posted Jun 06, 2025 - 11:26 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95% and Gemini Web UI: Uptime SLA 99.95%.