Gemini Credit Card Bonus Merchant Rewards Not Credited for Transactions Between 9:00-9:30 AM EST
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Oct 02, 2024 - 16:00 EDT
Investigating
We are aware of an issue with Gemini credit card bonus merchant-specific reward offers for transactions made between 9:00 and 9:30 AM EST on 9/20. We are working to ensure that bonus merchant rewards for eligible transactions are credited as soon as possible. Regular transaction rewards were not affected.
Posted Sep 20, 2024 - 14:33 EDT
This incident affected: Gemini Credit Card™.