Service disruption - Crypto deposit address generation, withdrawals, and transfer history are temporarily unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 11:16 EDT
Investigating
The generation of crypto deposit addresses, withdrawals, and transfer history is temporarily unavailable. We are currently investigating this issue. All customer accounts and funds remain secure. We will provide further updates as they become available.
Posted Mar 15, 2024 - 00:45 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95%, Gemini Web UI: Uptime SLA 99.95%, and Crypto Deposits and Withdrawals.