Non-USD Fiat Withdrawals Temporarily Unavailable
Incident Report for Gemini Exchange
Resolved
This issue is now resolved.
Posted Mar 25, 2021 - 21:12 EDT
Identified
We are currently working to resolve an issue impacting withdrawals of all non-USD Fiat currencies.
Posted Mar 25, 2021 - 19:58 EDT
This incident affected: Gemini ActiveTrader™, Gemini Web UI, Gemini Mobile App, and Wire Transfer Deposit and Withdrawals.