Delays in Marking Crypto Withdrawals as Successful

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted May 12, 2025 - 16:41 EDT

Investigating

We are currently investigating delays in marking crypto withdrawals as successful for some customers. All customer accounts and funds remain secure. Further updates to follow.
Posted May 12, 2025 - 13:10 EDT
This incident affected: Crypto Deposits and Withdrawals.