ID Upload Degraded on iOS 18.4 Mobile App

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Jun 16, 2025 - 16:31 EDT

Investigating

iOS 18.4 Mobile App users are currently experiencing an issue with ID upload. Team is aware and working on a fix. All customers funds remain secure.
Posted May 20, 2025 - 10:41 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95%.