Service Disruption - Wire Transfers
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Nov 16, 2022 - 14:02 EST
Identified
Gemini has implemented a fix to accelerate the rate at which queued wire transfers are processed and will be continuing to monitor.
Posted Nov 16, 2022 - 12:26 EST
Monitoring
Gemini has implemented a fix to accelerate the rate at which queued wire transfers are processed and will be continuing to monitor.
Posted Nov 16, 2022 - 12:26 EST
Identified
Gemini has identified an incident impacting wire transfers. All funds remain secure as we work to fully restore service. We will be actively updating the status of the exchange and will continue to do so for future events here:
Posted Nov 16, 2022 - 12:14 EST
This incident affected: Wire Transfer Deposit and Withdrawals.