Service Disruption - Crypto Withdrawals

Incident Report for Gemini Exchange

Resolved

This incident has been resolved, normal service has been restored.
Posted Dec 18, 2025 - 14:40 EST

Investigating

We are investigating issues impacting withdrawals of crypto assets. Users may experience delays or error messages when attempting to initiate new crypto withdrawals from the exchange. Customer funds remain secure and we will share further updates here as our investigation progresses.
Posted Dec 18, 2025 - 13:57 EST
This incident affected: Crypto Deposits and Withdrawals.