ETH/ERC20 withdrawals delayed
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Aug 23, 2024 - 08:48 EDT
Investigating
We are currently investigating an issue causing delays with ETH/ERC20 withdrawals. All customer assets and funds remain secure. We will update this page as more information becomes available.
Posted Aug 23, 2024 - 07:26 EDT
This incident affected: Crypto Deposits and Withdrawals.