BTC Withdrawal Requests
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted 21 days ago. Sep 29, 2018 - 13:22 EDT
Investigating
A small subset of BTC withdrawal requests are not being processed. Gemini is working to resolve this issue. All customer assets remain secure.
Posted 21 days ago. Sep 29, 2018 - 10:14 EDT
This incident affected: Bitcoin Deposits & Withdrawals.