Executed order history degraded 11/25/2024
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Nov 25, 2024 - 13:21 EST
Investigating
We are experiencing delays in executed orders appearing in customer order history. All customer accounts and funds remain completely secure. Updates will be provided once they are available.
Posted Nov 25, 2024 - 11:13 EST
This incident affected: Gemini Mobile App: Uptime SLA 99.95%, Gemini Web UI: Uptime SLA 99.95%, and REST API.