Delays to Wire Deposits & Withdrawals Processing
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jan 03, 2025 - 16:57 EST
Investigating
We are currently investigating an issue delaying wire deposit processing. All customer accounts and funds remain secure. Further updates to follow.
Posted Jan 02, 2025 - 13:14 EST
This incident affected: Fiat Deposits and Withdrawals.