Crypto Deposits Degraded Performance

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted May 28, 2025 - 17:41 EDT

Investigating

LTC, DOGE, BCH, AVAX, and DOT deposits are experiencing degraded performance. All customer accounts and funds remain completely secure. Updates will be provided once they are available.
Posted May 28, 2025 - 10:58 EDT
This incident affected: Digital Currencies (Litecoin Deposits and Withdrawals, Bitcoin Cash Deposits and Withdrawals, Dogecoin Deposits and Withdrawals, Polkadot Deposits and Withdrawals, Avalanche Deposits and Withdrawals).