Login issues to web and mobile
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted about 1 month ago. Jun 20, 2019 - 19:11 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Jun 20, 2019 - 18:50 EDT
Investigating
We are currently investigating an issue with logins to the Exchange web and mobile portals. All customers’ assets remain secure. We will provide further updates as necessary.
Posted about 1 month ago. Jun 20, 2019 - 18:33 EDT
This incident affected: Exchange Web Interface.