Tezos Deposits Experiencing Delays
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Sep 07, 2021 - 16:53 EDT
Identified
We are currently working to resolve an issue impacting Tezos deposit processing times.
Posted Sep 07, 2021 - 16:44 EDT
This incident affected: Digital Currencies (Tezos Deposits & Withdrawals).