Service Disruption - Optimism Withdrawals
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jun 28, 2024 - 10:20 EDT
Investigating
We are currently investigating an issue causing Optimism deposits and withdrawals to be delayed. All customer funds and assets remain secure. We will update this page with more information as it becomes available.
Posted Jun 26, 2024 - 20:12 EDT
This incident affected: Digital Currencies (Optimism Deposits and Withdrawals).