Partial Outage - eOTC Interfaces

Incident Report for Gemini Exchange

Resolved

This incident has been resolved and access has been restored.
Posted 24 days ago. Mar 16, 2025 - 20:26 EDT

Investigating

We are investigating reports of some users being unable to access the eOTC tab via the web interface. We will share further updates here as our investigation progresses.
Posted 24 days ago. Mar 16, 2025 - 09:42 EDT
This incident affected: Gemini eOTC.