Blank trading screen in mobile advanced mode
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Feb 01, 2024 - 20:08 EST
Investigating
All customer accounts and funds remain completely secure. Further updates to follow.
Posted Feb 01, 2024 - 11:06 EST
This incident affected: Gemini Mobile App.