XRP deposits & withdrawals unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Feb 04, 2025 - 19:33 EST
Update
We are continuing to investigate this issue.
Posted Feb 04, 2025 - 19:06 EST
Investigating
We are currently investigating an issue affecting XRP deposits and withdrawals. All customer accounts and funds remain secure. Further updates to follow.
Posted Feb 04, 2025 - 17:43 EST
This incident affected: Digital Currencies (XRP Deposits & Withdraw).