Portfolio Balance Temporarily Unavailable

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 09:56 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 28, 2025 - 17:23 EDT

Investigating

We are currently investigating an issue impacting the visibility of user portfolio balances on the Gemini exchange. All customer accounts and funds remain secure. Further updates to follow.
Posted Aug 28, 2025 - 16:43 EDT
This incident affected: Gemini.com website.