Degraded performance for Fiat Withdrawals
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Sep 26, 2024 - 21:09 EDT
Investigating
We are currently investigating effecting fiat withdrawals. All customer accounts and funds remain secure. Further updates to follow.
Posted Sep 26, 2024 - 20:36 EDT
This incident affected: Fiat Deposits and Withdrawals.