Synthetix Network Deposits & Withdrawals
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Dec 22, 2020 - 19:34 EST
Monitoring
Synthetix Network Deposits & Withdrawals are unavailable while network maintenance is performed.
Posted Dec 22, 2020 - 16:27 EST
This incident affected: Digital Currencies (Synthetix Network Deposits & Withdrawals).