Service Disruption - Delayed Fiat Transfers for UK Customers

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 18:16 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 12, 2025 - 11:01 EDT

Investigating

Our team is currently investigating an issue that affects GBP Deposits and Withdrawals and EUR Deposits for UK Customers.

All customer accounts and funds remain secure. All customer accounts and funds remain secure. Further updates to follow.
Posted Aug 12, 2025 - 07:05 EDT
This incident affected: Fiat Deposits and Withdrawals.