Crypto Deposit Delays, Crypto Withdrawal Submission Failures, and Staking Reward Delays

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Feb 22, 2026 - 10:31 EST

Update

We are continuing to investigate this issue.
Posted Feb 22, 2026 - 10:31 EST

Update

We are continuing to investigate this issue.
Posted Feb 22, 2026 - 02:37 EST

Investigating

Customers may experience delays in crypto deposit processing, failures when submitting crypto withdrawal requests, and delays in receiving staking rewards. All customer accounts and funds remain completely secure. Updates will be provided once they are available.
Posted Feb 22, 2026 - 02:36 EST
This incident affected: Crypto Deposits and Withdrawals.