Service Disruption - Mobile and Web UI
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 14:54 EST
Investigating
Gemini is investigating reports of potential service disruptions on Gemini ActiveTrader™, Gemini Web UI, and the Gemini Mobile App. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Nov 17, 2020 - 14:41 EST
This incident affected: Gemini ActiveTrader™, Gemini Web UI, and Gemini Mobile App.